re = /(^\*+.*\*+$\n)(?:.*\n)+?(?=^\*+.*\*+$\n)/m
str = '********** Field #1 **********
Content inside Field #1
More content
********** Field #2 **********
Content inside Field #2
More content
********** Field #2 **********
Content inside Field #2
More content'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end