package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bcreate(?:\s*/\*[^*]*\*+(?:[^/*][^*]*\*+)*/)*\s*table\b`)
var str = `1: 2637:1888 log :[INFO] : create table mytab (n numeric)
2: 2637:1888 log :[INFO] : create /* some comment*/ table mytab (n numeric)
3: 2637:1888 log :[INFO] : create /* some comment*/ /**//* some comment2*/ table mytab (n numeric)
4: 2637:1888 log :[INFO] : create WOW table mytab (n numeric)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}