// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bcreate(?:\s*/\*[^*]*\*+(?:[^/*][^*]*\*+)*/)*\s*table\b").unwrap();
let string = "1: 2637:1888 log :[INFO] : create table mytab (n numeric)
2: 2637:1888 log :[INFO] : create /* some comment*/ table mytab (n numeric)
3: 2637:1888 log :[INFO] : create /* some comment*/ /**//* some comment2*/ table mytab (n numeric)
4: 2637:1888 log :[INFO] : create WOW table mytab (n numeric)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}