import Foundation
let pattern = #"\bcreate(?:\s*/\*[^*]*\*+(?:[^/*][^*]*\*+)*/)*\s*table\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1: 2637:1888 log :[INFO] : create table mytab (n numeric)
2: 2637:1888 log :[INFO] : create /* some comment*/ table mytab (n numeric)
3: 2637:1888 log :[INFO] : create /* some comment*/ /**//* some comment2*/ table mytab (n numeric)
4: 2637:1888 log :[INFO] : create WOW table mytab (n numeric)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)