$re = '~\bcreate(?:\s*/\*[^*]*\*+(?:[^/*][^*]*\*+)*/)*\s*table\b~m';
$str = '1: 2637:1888 log :[INFO] : create table mytab (n numeric)
2: 2637:1888 log :[INFO] : create /* some comment*/ table mytab (n numeric)
3: 2637:1888 log :[INFO] : create /* some comment*/ /**//* some comment2*/ table mytab (n numeric)
4: 2637:1888 log :[INFO] : create WOW table mytab (n numeric)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);