# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bcreate(?:\s*/\*[^*]*\*+(?:[^/*][^*]*\*+)*/)*\s*table\b"
test_str = ("1: 2637:1888 log :[INFO] : create table mytab (n numeric)\n"
"2: 2637:1888 log :[INFO] : create /* some comment*/ table mytab (n numeric)\n"
"3: 2637:1888 log :[INFO] : create /* some comment*/ /**//* some comment2*/ table mytab (n numeric)\n"
"4: 2637:1888 log :[INFO] : create WOW table mytab (n numeric)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.