use strict;
my $str = '1: 2637:1888 log :[INFO] : create table mytab (n numeric)
2: 2637:1888 log :[INFO] : create /* some comment*/ table mytab (n numeric)
3: 2637:1888 log :[INFO] : create /* some comment*/ /**//* some comment2*/ table mytab (n numeric)
4: 2637:1888 log :[INFO] : create WOW table mytab (n numeric)';
my $regex = qr~\bcreate(?:\s*/\*[^*]*\*+(?:[^/*][^*]*\*+)*/)*\s*table\b~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}