#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[+-]?(?:\d+|\d{1,3}(?:,\d{3})*)(?:\.\d*)?$"
Local $sString = "10000" & @CRLF & _
"100,000,000" & @CRLF & _
"100,000,000.345345" & @CRLF & _
"10000.689" & @CRLF & _
"10000000.56" & @CRLF & _
"10000000" & @CRLF & _
"" & @CRLF & _
"123,344.456" & @CRLF & _
"1234556" & @CRLF & _
"123456.124" & @CRLF & _
"-1234" & @CRLF & _
"-123,456,789" & @CRLF & _
"+1234.67" & @CRLF & _
"" & @CRLF & _
"10000,000,000.34534" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")