package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+-]?(?:\d+|\d{1,3}(?:,\d{3})*)(?:\.\d*)?$`)
var str = `10000
100,000,000
100,000,000.345345
10000.689
10000000.56
10000000
123,344.456
1234556
123456.124
-1234
-123,456,789
+1234.67
10000,000,000.34534
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}