re = /^[+-]?(?:\d+|\d{1,3}(?:,\d{3})*)(?:\.\d*)?$/m
str = '10000
100,000,000
100,000,000.345345
10000.689
10000000.56
10000000
123,344.456
1234556
123456.124
-1234
-123,456,789
+1234.67
10000,000,000.34534
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end