using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[+-]?(?:\d+|\d{1,3}(?:,\d{3})*)(?:\.\d*)?$";
string input = @"10000
100,000,000
100,000,000.345345
10000.689
10000000.56
10000000
123,344.456
1234556
123456.124
-1234
-123,456,789
+1234.67
10000,000,000.34534
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}