import re
regex = re.compile(r"^[+-]?(?:\d+|\d{1,3}(?:,\d{3})*)(?:\.\d*)?$", flags=re.MULTILINE)
test_str = ("10000\n"
"100,000,000\n"
"100,000,000.345345\n"
"10000.689\n"
"10000000.56\n"
"10000000\n\n"
"123,344.456\n"
"1234556\n"
"123456.124\n"
"-1234\n"
"-123,456,789\n"
"+1234.67\n\n"
"10000,000,000.34534\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")