#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)assert(?:false|(?:not)?null|true)\([^(),]*(?:\([^)]*\))*\);"
Local $sString = "// ok" & @CRLF & _
"assertFalse(",", Boolean.FALSE);" & @CRLF & _
"assertFalse("", Boolean.FALSE);" & @CRLF & _
"assertFalse("ab" + "cd" + "de", Boolean.FALSE);" & @CRLF & _
"assertFalse(errorMessage, Boolean.FALSE);" & @CRLF & _
"assertFalse(errorMessage.toString(), Boolean.FALSE);" & @CRLF & _
"assertFalse("Assertion failed, because: " + errorMessage.toString(), Boolean.FALSE);" & @CRLF & _
"" & @CRLF & _
"// nok " & @CRLF & _
"assertFalse(Boolean.FALSE);" & @CRLF & _
"assertFalse(expectedMessage.endsWith("ab,cd"));"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")