package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)assert(?:false|(?:not)?null|true)\([^(),]*(?:\([^)]*\))*\);`)
var str = `// ok
assertFalse(",", Boolean.FALSE);
assertFalse("", Boolean.FALSE);
assertFalse("ab" + "cd" + "de", Boolean.FALSE);
assertFalse(errorMessage, Boolean.FALSE);
assertFalse(errorMessage.toString(), Boolean.FALSE);
assertFalse("Assertion failed, because: " + errorMessage.toString(), Boolean.FALSE);
// nok
assertFalse(Boolean.FALSE);
assertFalse(expectedMessage.endsWith("ab,cd"));`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}