// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)assert(?:false|(?:not)?null|true)\([^(),]*(?:\([^)]*\))*\);").unwrap();
let string = "// ok
assertFalse(\",\", Boolean.FALSE);
assertFalse(\"\", Boolean.FALSE);
assertFalse(\"ab\" + \"cd\" + \"de\", Boolean.FALSE);
assertFalse(errorMessage, Boolean.FALSE);
assertFalse(errorMessage.toString(), Boolean.FALSE);
assertFalse(\"Assertion failed, because: \" + errorMessage.toString(), Boolean.FALSE);
// nok
assertFalse(Boolean.FALSE);
assertFalse(expectedMessage.endsWith(\"ab,cd\"));";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}