$re = '/assert(?:false|(?:not)?null|true)\([^(),]*(?:\([^)]*\))*\);/i';
$str = '// ok
assertFalse(",", Boolean.FALSE);
assertFalse("", Boolean.FALSE);
assertFalse("ab" + "cd" + "de", Boolean.FALSE);
assertFalse(errorMessage, Boolean.FALSE);
assertFalse(errorMessage.toString(), Boolean.FALSE);
assertFalse("Assertion failed, because: " + errorMessage.toString(), Boolean.FALSE);
// nok
assertFalse(Boolean.FALSE);
assertFalse(expectedMessage.endsWith("ab,cd"));';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);