import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "assert(?:false|(?:not)?null|true)\\([^(),]*(?:\\([^)]*\\))*\\);";
final String string = "// ok\n"
+ "assertFalse(\",\", Boolean.FALSE);\n"
+ "assertFalse(\"\", Boolean.FALSE);\n"
+ "assertFalse(\"ab\" + \"cd\" + \"de\", Boolean.FALSE);\n"
+ "assertFalse(errorMessage, Boolean.FALSE);\n"
+ "assertFalse(errorMessage.toString(), Boolean.FALSE);\n"
+ "assertFalse(\"Assertion failed, because: \" + errorMessage.toString(), Boolean.FALSE);\n\n"
+ "// nok \n"
+ "assertFalse(Boolean.FALSE);\n"
+ "assertFalse(expectedMessage.endsWith(\"ab,cd\"));";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}