using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"assert(?:false|(?:not)?null|true)\([^(),]*(?:\([^)]*\))*\);";
string input = @"// ok
assertFalse("","", Boolean.FALSE);
assertFalse("", Boolean.FALSE);
assertFalse(""ab"" + ""cd"" + ""de"", Boolean.FALSE);
assertFalse(errorMessage, Boolean.FALSE);
assertFalse(errorMessage.toString(), Boolean.FALSE);
assertFalse(""Assertion failed, because: "" + errorMessage.toString(), Boolean.FALSE);
// nok
assertFalse(Boolean.FALSE);
assertFalse(expectedMessage.endsWith(""ab,cd""));";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}