#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*):(.*):(.*):((Fabric & Home Care)):(.*):(.*):(.*):(.*):(critical__c):(.*):((?!null)(?=[\w\ ]{4,}).*):(.*):(.*):(.*):(.*):(.*)$"
Local $sString = "Tide:Laundry Detergent:Laundry:Fabric & Home Care:Fabric Care:923217:101206518:false:critical__c::ss s:label_coding_insert_missing_incorrect__c:10221:false:false:UNITED STATES-US"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")