re = /^(.*):(.*):(.*):((Fabric & Home Care)):(.*):(.*):(.*):(.*):(critical__c):(.*):((?!null)(?=[\w\ ]{4,}).*):(.*):(.*):(.*):(.*):(.*)$/m
str = 'Tide:Laundry Detergent:Laundry:Fabric & Home Care:Fabric Care:923217:101206518:false:critical__c::ss s:label_coding_insert_missing_incorrect__c:10221:false:false:UNITED STATES-US'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end