const regex = new RegExp('^(.*):(.*):(.*):((Fabric & Home Care)):(.*):(.*):(.*):(.*):(critical__c):(.*):((?!null)(?=[\\w\\ ]{4,}).*):(.*):(.*):(.*):(.*):(.*)$', 'gm')
const str = `Tide:Laundry Detergent:Laundry:Fabric & Home Care:Fabric Care:923217:101206518:false:critical__c::ss s:label_coding_insert_missing_incorrect__c:10221:false:false:UNITED STATES-US`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}