using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w+)\s+(\w+)\s*,\s*(\w+).*";
string substitution = @"\1\2\3";
string input = @"RUIZ JIMENO, ALBERTO ADRIAN => RUIZJIMENOALBERTO
LÓPEZ FAUSTO, CATALINA DE MIGUEL => LOPEZFAUSTOCATALINA";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}