package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+)\s+(\w+)\s*,\s*(\w+).*`)
var str = `RUIZ JIMENO, ALBERTO ADRIAN => RUIZJIMENOALBERTO
LÓPEZ FAUSTO, CATALINA DE MIGUEL => LOPEZFAUSTOCATALINA`
var substitution = "\1\2\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}