$re = '/^(\w+)\s+(\w+)\s*,\s*(\w+).*/mu';
$str = 'RUIZ JIMENO, ALBERTO ADRIAN => RUIZJIMENOALBERTO
LÓPEZ FAUSTO, CATALINA DE MIGUEL => LOPEZFAUSTOCATALINA';
$subst = "\1\2\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;