use strict;
my $str = 'RUIZ JIMENO, ALBERTO ADRIAN => RUIZJIMENOALBERTO
LÓPEZ FAUSTO, CATALINA DE MIGUEL => LOPEZFAUSTOCATALINA';
my $regex = qr/^(\w+)\s+(\w+)\s*,\s*(\w+).*/mup;
my $subst = '\\1\\2\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";