re = /^(\w+)\s+(\w+)\s*,\s*(\w+).*/m
str = 'RUIZ JIMENO, ALBERTO ADRIAN => RUIZJIMENOALBERTO
LÓPEZ FAUSTO, CATALINA DE MIGUEL => LOPEZFAUSTOCATALINA'
subst = '\\1\\2\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result