package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:"([^"\\]*(?:\\[\S\s][^"\\]*)*)"|'([^'\\]*(?:\\[\S\s][^'\\]*)*)'|([^'"\\]+)|(\\[\S\s]))`)
var str = `Telling myself 'you are \'great\' ' and then saying "thank you" feels "a \"little\" nice"`
var substitution = "$1$2$3$4\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}