import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\"([^\"\\\\]*(?:\\\\[\\S\\s][^\"\\\\]*)*)\"|'([^'\\\\]*(?:\\\\[\\S\\s][^'\\\\]*)*)'|([^'\"\\\\]+)|(\\\\[\\S\\s]))";
final String string = "Telling myself 'you are \\'great\\' ' and then saying \"thank you\" feels \"a \\\"little\\\" nice\"";
final String subst = "$1$2$3$4\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}