const regex = /(?:"([^"\\]*(?:\\[\S\s][^"\\]*)*)"|'([^'\\]*(?:\\[\S\s][^'\\]*)*)'|([^'"\\]+)|(\\[\S\s]))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:"([^"\\\\]*(?:\\\\[\\S\\s][^"\\\\]*)*)"|\'([^\'\\\\]*(?:\\\\[\\S\\s][^\'\\\\]*)*)\'|([^\'"\\\\]+)|(\\\\[\\S\\s]))', 'gm')
const str = `Telling myself 'you are \\'great\\' ' and then saying "thank you" feels "a \\"little\\" nice"`;
const subst = `$1$2$3$4\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);