use strict;
my $str = 'Telling myself \'you are \\\'great\\\' \' and then saying "thank you" feels "a \\"little\\" nice"';
my $regex = qr/(?:"([^"\\]*(?:\\[\S\s][^"\\]*)*)"|'([^'\\]*(?:\\[\S\s][^'\\]*)*)'|([^'"\\]+)|(\\[\S\s]))/mp;
my $subst = '$1$2$3$4\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";