re = /(?:"([^"\\]*(?:\\[\S\s][^"\\]*)*)"|'([^'\\]*(?:\\[\S\s][^'\\]*)*)'|([^'"\\]+)|(\\[\S\s]))/m
str = 'Telling myself \'you are \\\'great\\\' \' and then saying "thank you" feels "a \\"little\\" nice"'
subst = '$1$2$3$4\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result