using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d$)";
string substitution = @"\1,";
string input = @"1, 83, 1, 89, 152, 78, 25.54051, 1, 1, 0, 0, 0, 1, 0, 1, ""1/13/97"", ""1/18/97"", ""12/31/02"", 5, 0, 2178, 0
2, 49, 1, 84, 120, 60, 24.02398, 1, 0, 0, 0, 0, 0, 1, 1, ""1/19/97"", ""1/24/97"", ""12/31/02"", 5, 0, 2172, 0
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}