import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d$)";
final String string = "1, 83, 1, 89, 152, 78, 25.54051, 1, 1, 0, 0, 0, 1, 0, 1, \"1/13/97\", \"1/18/97\", \"12/31/02\", 5, 0, 2178, 0\n"
+ "2, 49, 1, 84, 120, 60, 24.02398, 1, 0, 0, 0, 0, 0, 1, 1, \"1/19/97\", \"1/24/97\", \"12/31/02\", 5, 0, 2172, 0\n";
final String subst = "\\1,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}