re = /(\d$)/m
str = '1, 83, 1, 89, 152, 78, 25.54051, 1, 1, 0, 0, 0, 1, 0, 1, "1/13/97", "1/18/97", "12/31/02", 5, 0, 2178, 0
2, 49, 1, 84, 120, 60, 24.02398, 1, 0, 0, 0, 0, 0, 1, 1, "1/19/97", "1/24/97", "12/31/02", 5, 0, 2172, 0
'
subst = '\\1,'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result