#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![\d@.]*$)\w+(?:\.\w+){0,2}@\w+(?:\.\w+){0,2}$"
Local $sString = "111@111.111" & @CRLF & _
"something@something" & @CRLF & _
"some@some.com" & @CRLF & _
"some.some.some@heven.co.uk" & @CRLF & _
"" & @CRLF & _
"tushar.mahe123@gmail.com" & @CRLF & _
"" & @CRLF & _
"some.some.some.some@heven.co.uk.gov"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")