$re = '/^(?![\d@.]*$)\w+(?:\.\w+){0,2}@\w+(?:\.\w+){0,2}$/m';
$str = '111@111.111
something@something
some@some.com
some.some.some@heven.co.uk
tushar.mahe123@gmail.com
some.some.some.some@heven.co.uk.gov';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);