import re
regex = re.compile(r"^(?![\d@.]*$)\w+(?:\.\w+){0,2}@\w+(?:\.\w+){0,2}$", flags=re.MULTILINE)
test_str = ("111@111.111\n"
"something@something\n"
"some@some.com\n"
"some.some.some@heven.co.uk\n\n"
"tushar.mahe123@gmail.com\n\n"
"some.some.some.some@heven.co.uk.gov")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")