re = /^(?![\d@.]*$)\w+(?:\.\w+){0,2}@\w+(?:\.\w+){0,2}$/m
str = '111@111.111
something@something
some@some.com
some.some.some@heven.co.uk
tushar.mahe123@gmail.com
some.some.some.some@heven.co.uk.gov'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end