const regex = /^(?![\d@.]*$)\w+(?:\.\w+){0,2}@\w+(?:\.\w+){0,2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![\\d@.]*$)\\w+(?:\\.\\w+){0,2}@\\w+(?:\\.\\w+){0,2}$', 'gm')
const str = `111@111.111
something@something
some@some.com
some.some.some@heven.co.uk
tushar.mahe123@gmail.com
some.some.some.some@heven.co.uk.gov`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}