import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[a-z]+:[a-z\\d]+:[a-z]+:\\d+\\b";
final String string = "a:1a:b:0\n"
+ "a:1a:b:0a\n\n"
+ "test:1a2b3c:test:0bc\n"
+ "43test:1a2b3c:test:0bc\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}