const regex = /\b[a-z]+:[a-z\d]+:[a-z]+:\d+\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[a-z]+:[a-z\\d]+:[a-z]+:\\d+\\b', 'gmi')
const str = `a:1a:b:0
a:1a:b:0a
test:1a2b3c:test:0bc
43test:1a2b3c:test:0bc
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}