// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\b[a-z]+:[a-z\d]+:[a-z]+:\d+\b").unwrap();
let string = "a:1a:b:0
a:1a:b:0a
test:1a2b3c:test:0bc
43test:1a2b3c:test:0bc
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}