$re = '/\b[a-z]+:[a-z\d]+:[a-z]+:\d+\b/mi';
$str = 'a:1a:b:0
a:1a:b:0a
test:1a2b3c:test:0bc
43test:1a2b3c:test:0bc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);