re = /\b[a-z]+:[a-z\d]+:[a-z]+:\d+\b/mi
str = 'a:1a:b:0
a:1a:b:0a
test:1a2b3c:test:0bc
43test:1a2b3c:test:0bc
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end