import re
regex = re.compile(r"\b[a-z]+:[a-z\d]+:[a-z]+:\d+\b", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("a:1a:b:0\n"
"a:1a:b:0a\n\n"
"test:1a2b3c:test:0bc\n"
"43test:1a2b3c:test:0bc\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")