import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((20)?[012][0-9][ ,.,。、\\/\\--—年])?(0?[0-9]|1[012])[ ,.,。、\\/\\--—月](([012]?[0-9]|3[01])[ ,.,。、\\/\\--—号日](\\s*[0-5]?[0-9]分([::]?[0-5]?[0-9]秒)?)?)?";
final String string = "2020年3月3日";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}