re = /((20)?[012][0-9][ ,.,。、\/\--—年])?(0?[0-9]|1[012])[ ,.,。、\/\--—月](([012]?[0-9]|3[01])[ ,.,。、\/\--—号日](\s*[0-5]?[0-9]分([::]?[0-5]?[0-9]秒)?)?)?/m
str = '2020年3月3日'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end