use strict;
my $str = '2020年3月3日';
my $regex = qr/((20)?[012][0-9][ ,.,。、\/\--—年])?(0?[0-9]|1[012])[ ,.,。、\/\--—月](([012]?[0-9]|3[01])[ ,.,。、\/\--—号日](\s*[0-5]?[0-9]分([::]?[0-5]?[0-9]秒)?)?)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}