const regex = /((20)?[012][0-9][ ,.,。、\/\--—年])?(0?[0-9]|1[012])[ ,.,。、\/\--—月](([012]?[0-9]|3[01])[ ,.,。、\/\--—号日](\s*[0-5]?[0-9]分([::]?[0-5]?[0-9]秒)?)?)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((20)?[012][0-9][ ,.,。、\\\/\\--—年])?(0?[0-9]|1[012])[ ,.,。、\\\/\\--—月](([012]?[0-9]|3[01])[ ,.,。、\\\/\\--—号日](\\s*[0-5]?[0-9]分([::]?[0-5]?[0-9]秒)?)?)?', 'gm')
const str = `2020年3月3日`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}