// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((20)?[012][0-9][ ,.,。、\/\--—年])?(0?[0-9]|1[012])[ ,.,。、\/\--—月](([012]?[0-9]|3[01])[ ,.,。、\/\--—号日](\s*[0-5]?[0-9]分([::]?[0-5]?[0-9]秒)?)?)?").unwrap();
let string = "2020年3月3日";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}